• Posts tagged "gem"

Blog Archives

/home/live/.rvm/gems/ruby-2.0.0-p576@global/gems/mysql2-0.3.13/lib/mysql2.rb:8:in `require’: Incorrect MySQL client library version! This gem was compiled for 5.6.16 but the client library is 5.5.40. (RuntimeError)

/home/live/.rvm/gems/ruby-2.0.0-p576@global/gems/mysql2-0.3.13/lib/mysql2.rb:8:in `require’: Incorrect MySQL client library version! This gem was compiled for 5.6.16 but the client library is 5.5.40. (RuntimeError)

ubuntu环境

解决办法

升级ruby2.2.0后遇见的问题!

eventmachine

solve:

reference: https://github.com/eventmachine/eventmachine/issues/495

gem install therubyracer get error

gem install therubyracer get error

Solved

Reference

http://stackoverflow.com/questions/19697441/cannot-install-gem-therubyracer-in-os-x-mavericks

Rmagick memory leak

Rmagick memory leak

background

最近做图像处理上使用了Rmagick和MiniMagick, google了一下他们的区别,其中一段话印发了我一系列的思考。
Rmagick存在内存泄露问题。
(更多…)

rails remove test::unit

why?

because we use rspec as our test framework

how?

vim config/application.rb

ruby for js unescape

ruby for js unescape

最近由于项目接触到js escape后的字符串,需要解析,google了很多都没有查到具体的,于是便写了解析的方法

注:
escape() will not encode: @*/+
encodeURI() will not encode: ~!@#$&*()=:/,;?+’
encodeURIComponent() will not encode: ~!*()’
废话不多说,奉上代码:
(更多…)

An error occurred while installing nokogiri (1.5.5), and Bundler cannot continue.

An error occurred while installing nokogiri (1.5.5), and Bundler cannot continue.

解决bundle install 时nokogiri的报错