• Posts tagged "mysql"

Blog Archives

/home/live/.rvm/gems/ruby-2.0.0-p576@global/gems/mysql2-0.3.13/lib/mysql2.rb:8:in `require’: Incorrect MySQL client library version! This gem was compiled for 5.6.16 but the client library is 5.5.40. (RuntimeError)

/home/live/.rvm/gems/ruby-2.0.0-p576@global/gems/mysql2-0.3.13/lib/mysql2.rb:8:in `require’: Incorrect MySQL client library version! This gem was compiled for 5.6.16 but the client library is 5.5.40. (RuntimeError)

ubuntu环境

解决办法

mac homebrew 安装不同的mysql版本

mac homebrew 安装不同的mysql版本

homebrew

reference: http://brew.sh/

安装

1. 搜索不同的mysql版本

(更多…)

rails 切换数据库链接

# rails 切换数据库链接
## 环境
ruby 2.0
rails 4
activerecord 4.0
## 前沿
最近有个项目,需要在同一个rails项目中使用不同的数据库,看了一下activerecord源码,发现实现是这样的

####lib/active_record/connection_handling.rb

我们可以在我们项目使用:来切换数据库

CentOS6.3 lnmp环境搭建

CentOS6.3 lnmp环境搭建

  • 系统环境: CentOS6.3 32位bit版本
  • 软件环境: Nginx-1.2.7 + MySQL-5.5.27 + PHP-5.4.11

1.安装相关扩展以及编译工具

(更多…)

MySQL的安装与配置

MySQL的安装与配置 < MySQL学习指南(一) >

注:这里只讲CentOS的安装

(1).binary安装

查看系统位数(32位或者64位)

(1).下载对应的安装包
64位bit版本

32位bit版本

(更多…)